NI Home > Community > NI Discussion Forums

LabVIEW Embedded

Reply
Member
mcusir
Posts: 46
0 Kudos

lm3s8962 ping labview-tcp error?

LM3S8962_TCP error.png
Member
Tadek
Posts: 1
0 Kudos

Re: lm3s8962 ping labview-tcp error?

Have the same problem. I am new to NI forums , just started with Labview and Arm.
Member
Crowbar
Posts: 16
0 Kudos

Re: lm3s8962 ping labview-tcp error?

So what was the source of such behaviour?

Member
mcusir
Posts: 46
0 Kudos

Re: lm3s8962 ping labview-tcp error?

Re-read this post, currently no solution, ping labview-tcp no data is returned, the cable is good; also do not communicate through a router.

Active Participant
vitoi
Posts: 322
0 Kudos

Re: lm3s8962 ping labview-tcp error?

try:

 

ping "labview-tcp"

 

no slashes (/)

Active Participant
vitoi
Posts: 322

Re: lm3s8962 ping labview-tcp error?

I had the same problem and now it's fixed.

 

The default complier options are to use a DHCP server. I suspect you do not have a DHCP server.

 

You can go to the compiler options and change the option to use a DHCP server and assign an IP address. This way you will have an IP address to use for the example program. (You will still not be able to ping "labview-tcp" as I suspect this name translation is soemthign also done by the DHCP server (or similar)).

Active Participant
carlos_otiniano.
Posts: 461
0 Kudos

Re: lm3s8962 ping labview-tcp error?

also had problems to communicate between the card and the computer, I could rectify it by accessing the Project Connection prodiedades placing a static IP address

1.png

Active Participant
carlos_otiniano.
Posts: 461
0 Kudos

Re: lm3s8962 ping labview-tcp error?

This procedure wishes to Ethernet data transmission between ARM LM3S8962 evaluation board and a computer, this process began when a client connection to the microcontroller, the server started generating random data and send to the client program (for this illustrative example only have paired with a client), if the client program disconnects or lost the link, the transmission stops and the microcontroller stay pending a new connection, as in previous demonstrations employ two routines the first is responsible for the generation of messages on the screen of the card and the second Ethernet communication, more https://decibel.ni.com/content/docs/DOC-35105

3.png

Member
Bhaumikdarji
Posts: 3
0 Kudos

Re: lm3s8962 ping labview-tcp error?

Thanks for this.:smileyhappy:

 

Also following thread is useful: http://forums.ni.com/t5/LabVIEW/Why-isn-t-DHCP-working-on-my-ARM-application/td-p/1502728

 

 

Here are some snaps to make it more clear. ( These are also there in above thread.) 

 

Regards,

Bhaumik

Active Participant
carlos_otiniano.
Posts: 461
0 Kudos

Re: lm3s8962 ping labview-tcp error?

[ Edited ]

Bhaumikdarji escribió:

Thanks for this.:smileyhappy:

 

Also following thread is useful: http://forums.ni.com/t5/LabVIEW/Why-isn-t-DHCP-working-on-my-ARM-application/td-p/1502728

 

 

Here are some snaps to make it more clear. ( These are also there in above thread.) 

 

Regards,

Bhaumik


------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

interesting, but the question is for a specific target LM3S8962, the answers are generic to a ARM microcontroller?