NI Home > Community > NI Discussion Forums

Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Do you mean 
Reply
Active Participant
jyang72211
Posts: 1,443
0 Kudos

VISA Find Resource can't find USB-GPIB

When I tried to find my USB-GPIB resource through the VISA Find Resource node, I can't find it.  The resource is clearly shown when I drop down a visa resource constant and in MAX.  See attached picture.  I have tried all the options for the VISA Find Resource node already.  The resource is supposed to have an address of 3.  Thanks!

------------------------------------------------------------------

Kudos and Accepted as Solution are welcome!
Trusted Enthusiast
Albert.Geven
Posts: 3,371
0 Kudos

Re: VISA Find Resource can't find USB-GPIB

below is an inputstring that defines to search only in gpib.

You can see a complete list in the help of the function Find VISA Resource.

Did you try this input string?

And did you get an error and what did it tell you?

 

GPIB?*INSTR

 

Matches GPIB0::2::INSTR, GPIB1::1::1::INSTR, and GPIB-VXI1::8::INSTR.

greetings from the Netherlands
Active Participant
jyang72211
Posts: 1,443
0 Kudos

Re: VISA Find Resource can't find USB-GPIB

I tried ?*.  Shouldn't that gives me all resources?  I tried different serach things, and there were not error.  However, the GPIB that I want didn't appear.  

 

I am expecting GPIB0::3::INSTR, but I only got GPIB1::INTFC from the Find VISA Resources noe.  I am able to get the correct GPIB resources string through a regular resource constant and MAX.  See picture from my first post.  Thanks!

------------------------------------------------------------------

Kudos and Accepted as Solution are welcome!
Trusted Enthusiast
Albert.Geven
Posts: 3,371
0 Kudos

Re: VISA Find Resource can't find USB-GPIB

I'm not having a gpib interface at home and no gpib instr.

So I can't test today but it seems not to go into the gpib interface if you only supply ?*

 

greetings from the Netherlands
Active Participant
jyang72211
Posts: 1,443
0 Kudos

Re: VISA Find Resource can't find USB-GPIB

I will try this tomorrow when I have GPIB connection.  I will let you know what happen.  

------------------------------------------------------------------

Kudos and Accepted as Solution are welcome!
Active Participant
jyang72211
Posts: 1,443
0 Kudos

Re: VISA Find Resource can't find USB-GPIB

I tired it.  It doesn't work.  It seems like the problem comes from the fine visa resource node.  It fails to find all the resources, even MAX sees the resources.  

------------------------------------------------------------------

Kudos and Accepted as Solution are welcome!
Active Participant
jyang72211
Posts: 1,443
0 Kudos

Re: VISA Find Resource can't find USB-GPIB

See attached for the problem.  I can find my resource through a resource name control, but I can't find it through the Find VISA Resource node.  Why is that?  

------------------------------------------------------------------

Kudos and Accepted as Solution are welcome!
Member
Jorge_Fernández
Posts: 32
0 Kudos

Re: VISA Find Resource can't find USB-GPIB

Hello jyang7221,

 

I tried to reproduce the issue that you are experiencing with no success, it works fine for me. I would suggest you to run a repair or reinstall of NI-VISA as it seems to be a problem with the VISA Find Resource VI.

 

Regards,


Jorge
Applications Engineer
National Instruments
________________________________________
Certified LabVIEW Associate Developer (CLAD)