NI Home > Community > NI Discussion Forums

Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Do you mean 
Reply
Member
ArduinoProject
Posts: 6
0 Kudos
Accepted Solution

Problem of NI VISA driver configuration for Arduino R3 Uno

[ Edited ]

Good Morning, my name is Leong. Currently I have the problem of NI-VISA Driver configuration for Arduino. After I download the NI-VISA driver from NI website, I running NI-VISA drivers and select which type of hardware bus should I select. After I select the type of hardware bus, the NI-VISA prompt me to select the device ID that I have been installed, my device ID for Arduino R3 UNO is USB\VID_2341&PID_0043. I select my device ID and click the next button. I the click next button, the screen displayed as the below:

 

Installation Options Screen.jpg

 

I choose to install the generated files on this computer and click finish. After I click finish, the error screen displayed as below:

 

NI-VISA error message.jpg

 

May I know that what is the problem so I know how to solve the problem? Thank you for your kindness help.

 

Regards,

 

Leong

Trusted Enthusiast
Albert.Geven
Posts: 3,381

Re: Problem of NI VISA driver configuration for Arduino R3 Uno

do not use the device driver wizard, just select the serial port you need in VISA

greetings from the Netherlands
Member
ArduinoProject
Posts: 6
0 Kudos

Re: Problem of NI VISA driver configuration for Arduino R3 Uno

Thanks, Albert. I solved the problem based on your solution you provided. It works!

Trusted Enthusiast
Albert.Geven
Posts: 3,381
0 Kudos

Re: Problem of NI VISA driver configuration for Arduino R3 Uno

You were not the only one who tried the hard way. The instrument driver wizard should start with the remark:

Are you sure that there is no driver available on the instrument driver network

and are you sure that a serial port that has a driver installed already does not need a driver made by this wizard?

greetings from the Netherlands
Member
ArduinoProject
Posts: 6
0 Kudos

Re: Problem of NI VISA driver configuration for Arduino R3 Uno

Dear Albert Geven,

 

Thank you for your solution provided to me. I connect my device with Labview, it works.

I realized that serial port that has a driver installed already.

 

Regards,

Leong Yun Siong

Active Participant
Atom.
Posts: 504
0 Kudos

Re: Problem of NI VISA driver configuration for Arduino R3 Uno

add other useful links, greetings

  

Getting Started With the LabVIEW Interface for Arduino

http://vishots.com/getting-started-with-the-labview-interface-for-arduino/

 

 

Ready to get started?

https://decibel.ni.com/content/docs/DOC-16204