NI Home > Community > NI Discussion Forums
Reply
Member m-s
Member
m-s
Posts: 159
0 Kudos

... Instrument IO Assistant is not installed correctly.

Hello,

I am using LabView 7.1 Student Edition on Windows 2000. When I double click on Instrument I/O assistant in the block diagram, I get the following error :

"Measurement & Automation Explorer or the Instrument IO Assistant is not installed correctly. Please install these from LabVIEW Driver CD.".

Now, I assume that the driver CD is the one for NI 488.2. Our interface is an Agilent 82357A GPIB-USB connector and all its software is installed. I can send VISA commands to instruments connected to it using the Measurement & Automation Explorer (*IDN\n etc.).

I found a suggestion that I should uninstall and reinstall the Instrument IO Assistant from the LabVIEW CD and try again on ni.com. Done that - no good.

Measurement & Automation Explorer reports (under Software) that NI-488.2 (ver. 2.30) and NI-VISA (ver. 3.1) are installed. I have seen something like this error before - I installed LabVIEW first and the drivers later, and during the installation the installer kept complaining about missing drivers. However, I thought that when I installed them later, everything would be fine. Apparently, it isn't. Should I uninstall LabVIEW and VISA and 488.2, and reinstall, reversing the process ?

I do not know much about windows, but this is what a friend suggested. I am not sure if all that nonsense is needed.

Thanks.
Trusted Enthusiast
Albert.Geven
Posts: 3,290
0 Kudos

Re: ... Instrument IO Assistant is not installed correctly.

Hi
the order of installing is ok, Labview first and the IO driver cd's later.
I guess something went wrong during install, try to get the newest IO driver cd's.
The latest I know is the august 2006 version, you should be able to install these.
You can deinstall everything but I think if something went wrong during install, the deinstall is not guaranteed.
But the newest install can fix that.

greetings from the Netherlands
Member m-s
Member
m-s
Posts: 159
0 Kudos

Re: ... Instrument IO Assistant is not installed correctly.

I just spent 2 hours removing everything from the system. Then installing NI488.2 with VISA 3.1, then Agilent IO libraries suite 14.2, and then finally labview. It still prompted me for a driver's CD - does it not know that NI VISA etc. are already installed ? Anyways, I just double clicked on Instrument I/O assistant and it again gives me the same error message. What do I do next ? Install the latest version of VISA on this version 7.1 Labview installation ? I have VISA 3.1. The latest is version 4.

At my wit's end.
Trusted Enthusiast
Albert.Geven
Posts: 3,290
0 Kudos

Re: ... Instrument IO Assistant is not installed correctly.

Hi
The problem is the IOlibrary from Agilent.
VISA works but the instrumentIO assistant only works with the NI-visa and that one does not work with the agilent gpib card.
So you are out of luck.
The instrument IO assistant needs a bit more hooks into the library and as far as I know these are not available in the agilent vidsa library.
Sorry.
greetings from the Netherlands
Member m-s
Member
m-s
Posts: 159
0 Kudos

Re: ... Instrument IO Assistant is not installed correctly.

Thanks for the response.

I read somewhere on NI that version 14 of Agilent's IO libraries has to be used :

http://digital.ni.com/public.nsf/allkb/F7C187DBF09EBE1186256F550065BD32

I tried that. The problem is unchanged. If a piece of equipment does not work with Labview, then I wonder how do they sell it as being compatible with Labview. Its basically a dud.

What interface boards does NI Visa work with ? If that is what we need to buy, we will.
Trusted Enthusiast
Albert.Geven
Posts: 3,290
0 Kudos

Re: ... Instrument IO Assistant is not installed correctly.

LabVIEW works with the agilent IOcard, it is just the IO assistant that I personally never use that does not work.
For the real work on gpib I use mostly the usb gpib version from NI
Any of NI's gpib cards (not the oldest ones before the AT-GPIB card) will work

greetings from the Netherlands
Member m-s
Member
m-s
Posts: 159
0 Kudos

Re: ... Instrument IO Assistant is not installed correctly.

Thanks for the response.

Does that mean that I cannot use any of the vendor supplied VIs with Labview if I do not use Instrument I/O Assistant ? I am very new to Labview, so its possible I am missing something.
Knight of NI
Dennis_Knutson
Posts: 31,956
0 Kudos

Re: ... Instrument IO Assistant is not installed correctly.

What you can try to do is to first install the agilent driver and then NI-VISA. Make sure you have the latest version of NI-VISA as earlier ones didn't play nicely with agilent's. From previous posts on the subject of agilent GPIB devices, I think you also have to enable the tulip passport in MAX (Tools>NI-VISA>VISA Options>Passports). Then you can trying re-installing the I/O) Assistant. I don't know if the assistant will work but you should be able to use VISA Write and VISA Read and any instrument drivers that you may download from NI. I don't have a list of links handly but if you do a search of the forum for agilent visa, you';; probably find a good number of posts on the subject and links to knowledge base articles on making an agilent board work with LabVIEW.
Member m-s
Member
m-s
Posts: 159
0 Kudos

Re: ... Instrument IO Assistant is not installed correctly.

I just got off the phone after talking to Agilent support and they tell me that NI VISA *must* be installed before Agilent's IO libraries are - otherwise I would get a mess on my hands.

And yes, I did enable the Tulip thingy - you cannot even see your GPIB card in MAX without doing that. The problem is in the interplay of Labview, Agilent's VISA and National Instruments VISA.
Trusted Enthusiast
Albert.Geven
Posts: 3,290
0 Kudos

Re: ... Instrument IO Assistant is not installed correctly.

No problem with anything exept with the IO-assistant.
You can use LabVIEW Instrument drivers from all vendors.
greetings from the Netherlands