NI Home > Community > NI Discussion Forums

Instrument Control (GPIB, Serial, VISA, IVI)

Showing results for 
Search instead for 
Do you mean 
Reply
Active Participant
bmihura
Posts: 466
0 Kudos

Agilent USB Device not showing up in MAX

I have an Agilent 34972A Data Acquisition device which is not showing in in MAX (Measurement & Automation Explorer) on my computer. Details:

 

  • It is connected via USB.
  • On a previous computer, it appeared as a USB device in MAX with no hassle.
  • It shows up in Windows' Device Manager at Other devices >> 34972A. It has a yellow warning symbol and doesn't have a driver loaded.
  • I don't see an Agilent driver it might be conflicting with, but I enabled the tulip passport anyway.
  • I have MAX 5.1, NI-VISA 4.6.2, and Windows 7.

 

Any ideas on how to get MAX to see this Agilent device?

 

Member
mkossmann
Posts: 111
0 Kudos

Re: Agilent USB Device not showing up in MAX

[ Edited ]

Your system is missing the USBTMC driver.  What happens if you try to repair the problem showing up in Windows device manager ? Can you find the files austmc.sys austmc.cat and austmc.inf somewhere on your system ?

Active Participant
bmihura
Posts: 466
0 Kudos

Re: Agilent USB Device not showing up in MAX

I tried to repair it from the Device Manager with the "Update Driver..." button, but the automatic search did not find anything.

 

Apparently the USBTMC driver should be installed by NI-VISA, so I installed the latest version of NI-VISA and it still didn't work.

 

Even after installing NI-VISA, there is still no austmc.* on my system.

 

Other ideas?

Member
Ebensir
Posts: 1
0 Kudos

Re: Agilent USB Device not showing up in MAX

I have this same trouble, then I install the IO library 16.3 form Agilent. When I plug in USB port, the system insall this driver (34972A), this driver is for IVI.this is IVI driver. My pc's hardmanager can check this instrument. But the next problem coming, the MAX can not find this.

I checked my system there are 2 VISA in this pc: 1 :NI-VISA, 2:Agilent-VISA, NI-VISA is primary ,the Agilent is secondary, so I must ask NI and Agilent for help.

 

Hope it can help you.

Member
Tim-C
Posts: 68
0 Kudos

Re: Agilent USB Device not showing up in MAX

I could be wrong, but MAX generally only displays National Instruments hardware. If it's a 3rd party device that communicates over VISA, you normally can't see it in MAX and just test by selecting the port, such as COM 1.

 

TimC
National Instruments
Applications Engineer
Member
pankaj
Posts: 58

Re: Agilent USB Device not showing up in MAX

MAX does display 3rd party devices in most cases, as long as the drivers are installed and they are accessible to NI-VISA. This is specially true for USBTMC devices which should always show up as long as NI-VISA is installed. From the fact that there is an yellow exclamation mark on the device in device manager, it seems that there is some problem with the USBTMC driver.

 

Most (and probably all) vendors of VISA, including NI, ship a common driver for USBTMC devices. This driver is owned by the IVI Foundation and distributed via an IVI VISA Shared Installer (that ships with various VISA vendors' installers). The latest shipping version of this installer can be downloaded from here: http://www.ivifoundation.org/shared_components/Default.aspx. The last section in that page lists the IVI VISA shared installers. Please pick the one that corresponds to the bitness of your OS and install that. Hopefully that fixes it.