NI Home > Community > NI Discussion Forums

Industrial Communications

Reply
Active Participant
DirkW
Posts: 1,117
0 Kudos

NI-IndCom for Devicenet 2.1 API Beta is now available!

Our official NI-IndCom for Devicenet  2.1 Beta is now available from here: ftp://ftp.ni.com/support/ind_comm/devicenet/2.1/

We added a NI-Dnet 1.x.x compatible API for Master/Scanner Support.

 

here are some known issues and things to keep in mind.

 

1. Support for LabVIEW 2009 or later only/ no C support.

2. Can not be installed with older NI-DNET 1.x drivers in parallel. That means you can only have 8532 boards in one system not both older Dnet cards and new 8532 boards !!

3. It will upgrade existing 2.x installations automatically.

4. Existing  NI-DNET 1.x VIs should be loaded and function just fine without replacing anything manually.

5. Existing NI IndCom for Devicenet 2.x VIs should be loaded and function just fine without replacing anything manually.

 

6. There is currently no slave/device support available for the 8532 hardware, but we will add support in the near future.

7. As soon as we release the driver we will offer a C-Series cRIO module as well.

 

Please post your feedback/questions in this thread, so we keep it in one place.

 

DirkW

Member
Kyle203
Posts: 6
0 Kudos

Re: NI-IndCom for Devicenet 2.1 API Beta is now available!

We have a number of systems in the field that have PCI-DNET boards in them and would like to continue supporting those systems with updated LV executables.  However, we would be planning that newer systems will have the 8532 boards so will need to install the 2.x driver.  It is my understanding from the list of things to keep in mind that any executable we create with the development system having the 2.1 driver will not support the systems with the older cards?  If this is true, then the only solution is to build two versions of the executables one with the DNET 1.x version driver installed on the development system, upgrade the driver on the development system and build a second one to support the 8532 boards? It sure would be nice if we didn't have to do this.

 

Kyle

Member
systemcrash
Posts: 174
0 Kudos

Re: NI-IndCom for Devicenet 2.1 API Beta is now available!

Hello dirk and Kyle203,

 

I have PCI 8532 devicenet card in my system, the test unit has devicent implemented in it,

 

to verify devicenet is working or not we check whether we can read Devicenet vendor id, I have downoaded the latest driver NI-IndComDNET2.1-Beta1.

 

Thanks for the new update. I developed a VI which is very similar to GetIdentityAttrs VI which is in Example.

 

Port opens fine, but I cannot see connection being established.I always get the error Error -1074388991 occurred at Get DeviceNet Attribute.vi

 

I know connections are proper and the Device MAC ID and speed too. Pls throw some light.'

 

Attached is the VI and error image

 

Thanks

Active Participant
DirkW
Posts: 1,117
0 Kudos

Re: NI-IndCom for Devicenet 2.1 API Beta is now available!

Thanks for posting the feedback. That is exactly what we are looking for so we can make the right adjustments to our driver release startegy. 

For now yes you would have to make two executables. One for the old boards with the old driver and one with the new boards with the new driver.

Based on your feedback we will look into a way to cover both old and new boards. I will post again with more information on this.

 

DirkW

Active Participant
DirkW
Posts: 1,117

Re: NI-IndCom for Devicenet 2.1 API Beta is now available!

[ Edited ]

Hi systemcrash,

 

The error indicates a timeout situation. It looks like the new board needs a little longer to establish communication. Could you try increasing the "wait for state" timeout value to a value greater then 6000?

 

DirkW

Member
systemcrash
Posts: 174
0 Kudos

Re: NI-IndCom for Devicenet 2.1 API Beta is now available!

Even though time out value is set more than 10000 I am getting an time out error.

 

SInce the error out is connected to all the other VI's I am not able to close the port, and when i connect error constant for the close VI's I do get error object created is invalid. That is expected I think.

 

Any other suggestions Dirk?

Member
Kyle203
Posts: 6
0 Kudos

Re: NI-IndCom for Devicenet 2.1 API Beta is now available!

Hi Dirk,

Any idea when the configurator will be available for the 8532?  That would be really helpful during testing.

 

Thanks,

Kyle

Active Participant
DirkW
Posts: 1,117

Re: NI-IndCom for Devicenet 2.1 API Beta is now available!

Hi systemcrash,

 

Your error screenshot indicates that you are having NI-DNET, NI CAN and the beta driver installed on the same machine. I have a slightly later version on my machine and can reproduce the timeout error if it is below 6000 ms.

But it goes away if I adjust it higher. This version did fix an issue with both drivers installed in parallel. Could you try uninstalling the NI-Dnet and NI-CAN driver?

 

DirkW

Active Participant
DirkW
Posts: 1,117
0 Kudos

Re: NI-IndCom for Devicenet 2.1 API Beta is now available!

Hi Kyle,

 

What are you using the configurator for? If it is just importing the EDS file and testing some parameters, that is available in LV project if you add the device and find slave devices, you can add an EDS file and use a testpanel tool with it.

 

DirkW

Member
systemcrash
Posts: 174
0 Kudos

Re: NI-IndCom for Devicenet 2.1 API Beta is now available!

Thanks for your inputs Dirk, I could able to read Vendor ID.

 

I do have a new problem which I have started in another thread. Pls do reply.

 

Thanks