Showing results for 
Search instead for 
Did you mean: 
Reply

Functions >> FPGA Interface palette missing

Re: Functions >> FPGA Interface palette missing

Re-installing NI-RIO helped me fixing this problem.  Thanks, Jerry.
0 Kudos
Message 11 of 18 (2,403 Views)
Reply
0 Kudos

Re: Functions >> FPGA Interface palette missing

I am using FPGA 2010 and FPGA Interface palette is missing. I have tried to reinstall the FPGA module and NIRIO but to no avail. Please let me know if there are any other alternatives.

 

Sofia

0 Kudos
Message 12 of 18 (2,254 Views)
Reply
0 Kudos

Re: Functions >> FPGA Interface palette missing

I have a few guesses as to what could be the problem.


1) Is it possible that your palette is just not set to visible? Create a blank VI (not under an FPGA target), right-click on the block diagram, pin the dialog, select Customize >> Change Visible Palettes.

2) You posted on a really old post, so it is unclear to me what you meant by "tried to reinstall the FPGA module". Are you using the NI-5640R 1.5 driver DVD to do this? or are you using the LabVIEW FPGA 2010 disk to do this? You should be using the LabVIEW FPGA disk.

3) You might want to check if Measurement and Automation Explorer thinks you have LabVIEW FPGA installed. Open Measurement and Automation Explorer, expand the software tab on the left, then expand the LabVIEW 2010 node. You should see an element under the LabVIEW 2010 node that says something like "FPGA" or "FPGA Module." I can't remember off the top of my head.

 

 

Message 13 of 18 (2,247 Views)

Re: Functions >> FPGA Interface palette missing

Thank you sooo much. My palette was just not visible and option 1 fixed the problem.Smiley Happy .

0 Kudos
Message 14 of 18 (2,241 Views)
Reply
0 Kudos

Re: Functions >> FPGA Interface palette missing

Hello,

 

I have Labview FPGA 2010 Module installed in my pc with windows 7. I am using NIRIO 3.5.1. When I am working with blank VI the FPGA interface is visible. But when I am working in FPGA Project and making FPGA VI it is not present. I dont understand. I am unable to associate my FPGA VI with FPGA main.

 

Sofia

0 Kudos
Message 15 of 18 (2,239 Views)
Reply
0 Kudos

Re: Functions >> FPGA Interface palette missing

There are different palettes for FPGA VIs and Host (My Computer) VIs. The actual "association" between the Host and FPGA VIs happens in the Host VI when you configure the "Open FPGA VI Reference".

 

Make sure that your Host VI is under "My Computer", but not inside the target section in the project tree.

0 Kudos
Message 16 of 18 (2,226 Views)
Reply
0 Kudos

Re: Functions >> FPGA Interface palette missing

Come to think of it, you may want to start by looking at (and possibly copying and modifying) one of the FPGA examples. The FPGA examples can be found here: C:\Program Files\National Instruments\LabVIEW 2010\examples\instr\ni5640R\FPGA\<your target>. The path will contain "Program Files (x86)" instead of "Program Files" if you are on a 64-bit OS.

0 Kudos
Message 17 of 18 (2,225 Views)
Reply
0 Kudos
Highlighted

Re: Functions >> FPGA Interface palette missing

Yeah I got it. Now I can reference my FPGA VI from my host VI. Thank u

 

Sofia

0 Kudos
Message 18 of 18 (2,218 Views)
Reply
0 Kudos