NI Home > Community > NI Discussion Forums
Reply
Member
maggotsBrain
Posts: 31
0 Kudos
Accepted Solution

Installation of NI-SCOPE 3.8.7

Hello,

 

I have to install NI-SCOPE 3.8.7 to use a PCI 5105 High-speed digitizer. Though, when I try to do this, the installation resume indicates that some features cannot be installed either because there is a more recent version installed (but this is not a problem) or, because they are "incompatible with products already installed". In my case, these are the "LabView/LabWindows/CVI Real-Time Supports" and the "NI system configuration 5.0.0" which includes "LabView 2010/2009/8.6/8.5".

 

I am using a computer running under Windows XP, and the thing is it is a little old and many people used it before me. Consequently, it is an incredible mess and many anterior LabView versions are installed (v6.1/v7.1/v8.2.1/v8.5/v8.6/v2009/v2010). I have read that anterior LabVie versions have no impact on the latest ones but I have also read this: http://digital.ni.com/public.nsf/allkb/F41A941BE2AFAC47862574B100736584

 

What shall I do? I suppose that I can't bypass the installation of the features mentionned above if I want my device to work well but how can I solve my problem? Would deleting "LabVIEW 8.2.1 Run-Time Engine" files fix it? Or shall I uninstall all previous LabView versions?

 

Looking forward for answers.

Member
GDEV
Posts: 23
0 Kudos

Re: Installation of NI-SCOPE 3.8.7

Hi, I suspect the incompatibility for the "LabVIEW/LabWindows/CVI Real-Time Supports" features is a result of the fact that your system has a version of NI-DAQmx already installed (newer than the version incl. with the NI-SCOPE 3.8.7 distribution) and the NI-DAQmx "LabVIEW/LabWindows/CVI Real-Time Supports" features for the existing NI-DAQmx installation were not installed. Assuming that you are not planning to develop applications using LabVIEW or LabWindows/CVI Real-Time modules this is of no practical consequence to you. National Instruments driver distributions (like NI-SCOPE) often include support APIs (like the "NI System Configuration") or infrastructure components (for NI-SCOPE NI-DAQmx is threaded as one). For the NI-SCOPE distribution we have elected to NOT include the latest revisions of such components in order to minimize the system changes during software upgrades. Regards
Member
maggotsBrain
Posts: 31
0 Kudos

Re: Installation of NI-SCOPE 3.8.7

Does that mean that I won't be able to use the real-time module for sure? Or will it be possible considering that some anterior versions of might already be imstalled on my computer.

Member
maggotsBrain
Posts: 31
0 Kudos

Re: Installation of NI-SCOPE 3.8.7

Is LV real time module useful only if I need remote systems? Because in this case, I would not need it.

Member
GDEV
Posts: 23
0 Kudos

Re: Installation of NI-SCOPE 3.8.7

You could still use the Real-Time module. This simply requires that you first install the NI-DAQmx Real-Time Support features (by modifying the existing NI-DAQmx installation) prior to installing (or modifying) NI-SCOPE.
Member
GDEV
Posts: 23

Re: Is LV real time module useful only if I need remote systems?

Yes, the LabVIEW Real-Time module is used in many remote targets/systems sold by National Instruments.
Member
maggotsBrain
Posts: 31
0 Kudos

Re: Is LV real time module useful only if I need remote systems?

I'm afraid this doesn't work: when I try to load NI-SCOPE SFP, an error message tells me that DMF 2.7 (or later) is not installed and should be, same thing for DMF Runtime 1.2, DMF Exports 1.2 and DMF Calibration 1.2.

 

Any idea why?

Member
GDEV
Posts: 23
0 Kudos

Re: Error message when launching NI-SCOPE SFP

[ Edited ]

Could you please tell me which version of NI-DAQmx is currently installed on your system? You may determine the version by looking in Add/Remove Programs or launching MAX (Measurement and Automation Explorer) and expanding the software node.

Member
maggotsBrain
Posts: 31
0 Kudos

Re: Error message when launching NI-SCOPE SFP

the version used is: DAQmx 9.3.5

Member
GDEV
Posts: 23
0 Kudos

Re: Error message when launching NI-SCOPE SFP

[ Edited ]

If you have a Digitizer (NI-SCOPE supported device), could you please run self-test from MAX for this device?