NI Home > Community > NI Discussion Forums
Reply
Member
checker
Posts: 4
0 Kudos

My FP-DO-AC120 module is being read as DI in FP Explorer, Why?

FP Explorer is not regonizing my DO module. It says that my FP-DO-AC120 is an DI, so I can not output to the module. I have upraded to FP Explorer 2.03, so it does recognize my FP-TB-10 terminal base. It accurately sees all my other modules, but I only have one Do module.
Member
JohnM
Posts: 30
0 Kudos

Re: My FP-DO-AC120 module is being read as DI in FP Explorer, Why?

The reason why the FP-DO-AC120 shows up as a Discrete input is that the network module or FieldPoint Explorer did not recognize the new addition. The first step I would take is to upgrade the firmware that the network module is using. To check the current firmware of the network module you will need to be in FieldPoint Explorer, right click on the network module and select edit this device, next type revision for the modules name. Do not hit enter or the OK button since this will rename your module. You should now see a box to the right. This is the firmware revision that you are using. For the FP-1000/1001 you will need 0030, and for the FP-1600 you will need 0300. To obtain the most recent revision, you will need to go to the following web site:

ftp://ftp.ni
.com/support/fieldpoint/Update/

FP-1600: Download FPethernet0300.zip
FP-1000/1001 Download FPUpdate.zip

If upgrading the firmware does not fix the problem, then I recommend that you try FieldPoint Explorer 2.0.4 located at the following web site:

http://digital.ni.com/softlib.nsf/current?OpenView&Start=1&Count=500&Expand=3#3

If the above does not solve the problem you are seeing, please contact National Instruments Tech Support.

John M.
Member
checker
Posts: 4
0 Kudos

Re: My FP-DO-AC120 module is being read as DI in FP Explorer, Why?

John, Thanks for your suggestions, but I tried all of the recommended items and it did not work. Thank you for your time. -Chris
Active Participant
Aaron_G
Posts: 704

Re: My FP-DO-AC120 module is being read as DI in FP Explorer, Why?

First of all, check to see that your system meets the mininum requirements to use Dual Channel modules. FieldPoint Explorer must be version 2.0.2 or later (which you meet), and depending upon your network module, you must have firmware revision 201 or greater (FP-1600) or 28 or greater (FP-1000 and FP-1001).

Next we have to look at behavior of the system. In FieldPoint Explorer, empty slots in FP-TB-10's default to Discrete Inputs. This can mean one of two things for your system. First of all, it might mean that you have not re-detected your modules (right click on the comm resource in FieldPoint Explorer,choose Edit This Comm Resource and then choose Find Devices or start a new IAK file, create a new comm resource and choose Find Devices). If it still does not s
how up, it means that the module is not being recognized by the terminal base. Remove and re-insert the module as you may not have locked it in place the first time. When a module is inserted for the first time in a slot, the power and ready LED's on the FP-TB-10 should turn off and on.

If removing and re-inserting does not fix it, you can also try reseting the network module by right clicking on the network module and choosing Edit This Device. There is a check-box that says "Factory Configuration", check it and press the Reset button. You will then need to uncheck and re-do any configurations you have done for the modules attached to that network module, and should be able to do a Find Devices and have it detect it.

Regards,
Aaron
Member
checker
Posts: 4
0 Kudos

Re: My FP-DO-AC120 module is being read as DI in FP Explorer, Why?

Aaron,
Thank you for your help. I followed your suggestions and it worked. I'm not sure exactly which one worked because I just followed them all. Thank you again. -Chris