NI Home > Community > NI Discussion Forums

Feedback on NI Discussion Forums

Showing results for 
Search instead for 
Do you mean 
Reply
Knight of NI
Ray.R
Posts: 10,584
Accepted Solution

Unexpected behavior while trying to post reply

Here's the scenario:

 

Clicked reply within an existing thread to the last post.

The message window came up and I started typing text.

The message window refreshed, as it does occasionally and is annoying.

There was a typo due to the refresh dropping some letter.

I hit the "Backspace" key to erase the unwanted characters.

 

The message dissappeared and it took me to the first page of a 3 page thread.

 

I was not expecting that behavior. 

 

R

______________________________________________________________________
Kudos!!!! Gimme Kudos!!!! It's that little golden star on the left below my avatar... :smileyhappy:
Trusted Enthusiast
Posts: 2,700
0 Kudos

Re: Unexpected behavior while trying to post reply

That's happening to me since long months ago. :smileysad: You had the guts to post it JLV. :smileywink:

 

New probem in composer (I don't know whether somebody reported it anywhere):

 

Inside the composer box, if the cursor is at last line and if we press down arrow key the cursor moves outside the composer box.

 

Well, in the opposite way, if the cursor is at the very first line and if you press up arrow key, the cursor starts moving to toolbar above the composer box, then to subject line and get moved up and up......

 

Or this is the intentional behavior? :smileysurprised: I didn't see this behavior in any other composer box like yahoomail, gmail...... Correct me if i am wrong :smileyhappy:

Knight of NI
RavensFan
Posts: 16,018

Re: Unexpected behavior while trying to post reply

[ Edited ]

I've seen this happen quite a bit.  Basically the page takes too long to load.  Normally if you start typing even if it hasn't completely loaded, it will take your characters and fill them in once you get caught up.  I'm someone who definitely does not look at the keyboard while typing, and I don't necessarily need to look at the screen either.  Even if I haven't seen what I've typed, I'll know if I mistyped something and will instinctively go to Backspace to clear the character and retype.  Do this at the wrong time while the page is still loading and that backspace gets interpreted by the browser as Go Back rather than the editor portion as backspace.

 

Since I usually open threads by right clicking the number in the New column and open in new window, it takes me to the first of the unread messages.  But since I've already seen all the messages (I was just in the thread read them and wanted to reply to one), there are no new messages and the Go Back which takes it to the thread &jump=true,  automatically takes it back to the first message since there is no new message to jump to.

 

Very annoying, and the only way to get around it is to either get the browser to load the page quicker, or try to be patient and be sure it completely loads before you type and hit a backspace.

 

As a side note, I've noticed in recent months that my home Verizon DSL connection has been dropping pages where it takes longer to load, or eventually times out and doesn't load the page (with other websites besides NI as well), and I'm forced to reload to get the page.  Sometimes it loses it in the middle of the page where you basically see everything but the progress bar at the bottom is stalled loading something else.   Has anyone else who may be using Verizon DSL noticed this a more of a problem in recent months?  I don't notice very often at my work PC, so I'm thinking that the Verizon portion of the network is just not doing its job correctly in getting the packets across.

Message Edited by Ravens Fan on 09-17-2009 11:52 PM
Proven Zealot
muks
Posts: 7,208
0 Kudos

Re: Unexpected behavior while trying to post reply

I wouldnt say this is unexpected cos I have learnt to live with it. This happens when you want to type a quick reply and not otherwise. In otherwords if you wait for another couple of more seconds and allow the page to be completely refreshed then you dont see it. :smileywink:
Knight of NI
Ray.R
Posts: 10,584

Re: Unexpected behavior while trying to post reply


Ravens Fan wrote:

I've seen this happen quite a bit.  Basically the page takes too long to load.  Normally if you start typing even if it hasn't completely loaded, it will take your characters and fill them in once you get caught up.  I'm someone who definitely does not look at the keyboard while typing, and I don't necessarily need to look at the screen either.  Even if I haven't seen what I've typed, I'll know if I mistyped something and will instinctively go to Backspace to clear the character and retype.  Do this at the wrong time while the page is still loading and that backspace gets interpreted by the browser as Go Back rather than the editor portion as backspace.



 

This is exactly how it happens.  The slow loading page is REALLY annoying.

 

The page loading speed is inconsistent. 

______________________________________________________________________
Kudos!!!! Gimme Kudos!!!! It's that little golden star on the left below my avatar... :smileyhappy:
Knight of NI
Posts: 18,064

Re: Unexpected behavior while trying to post reply

[ Edited ]

Mathan wrote: 

New probem in composer (I don't know whether somebody reported it anywhere):


Don't get us started with the message composer. :smileymad:

 

P.S. The smiley-mad is aimed at the composer, not you. :smileywink:

Message Edited by smercurio_fc on 09-18-2009 09:11 AM
Knight of NI
Ray.R
Posts: 10,584

Re: Unexpected behavior while trying to post reply

Am I reading that a few people (who are major contributors to this forum) are not happy with the present message composer?

 

(I thought I was the only one)

______________________________________________________________________
Kudos!!!! Gimme Kudos!!!! It's that little golden star on the left below my avatar... :smileyhappy:
Knight of NI
RavensFan
Posts: 16,018

Re: Unexpected behavior while trying to post reply

I've learned to live with it for the most part, but I thought the old editor was better.

 

  1. Too small window.  You can resize it, but it doesn't always stick.  If the text more than fills the window, the scrollbars will jump if you hover your mouse over the bars just above or below the edit window.
  2. The smiley winky dialog box takes longer to load.  And I still don't think we need the man, woman, robot faces.  There ugly and they are impossible to see which face is which.
  3. The new picture button is nice for the most part.  But it could be a little quicker to load the dialog.  While I like the personal image storage area, I don't think using it for posting images tintended for specific messages is a good idea.  I think the image should be attached to the particular message where it is used in 99% of the cases.  The risk is that if you post an example to someone's message and the image is stored in your personal area, if you ever decide to go clean up your image area, you don't know where the images were used, and if you delete them, the image in that message is going to get broken.  I still prefer to attach the image file to the message and embed the image in the text body.  But that still requires, attach, post, edit, insert image, post again.  And is now actually a step or two longer than it used to be as you navigate through the more sophisticated dialog box.  I think the webserver should be smart enough that when you embed an image, it automatically attaches the file, and once posted, the webpage is relinked so the image URL is changed from the temporary location and points to the permanent location of the file attachment with the message ID.
  4. The editor does seem to be a bit slower to load than before.
Knight of NI
Posts: 18,064

Re: Unexpected behavior while trying to post reply


Ray.R wrote:

Am I reading that a few people (who are major contributors to this forum) are not happy with the present message composer?

 

(I thought I was the only one)


There have been numerous complaints about the new and "improved" editor. Most were posted in the several threads that talked about the upgrades to the forum. I don't find that much improvement with it at all. The space deletion at the end of a line that it does is so maddeningly frustrating and Lithium has yet to fix it. And the reformatting it does when you switch back and forth between HTML-editing and "graphical"-editing is bizarre and completely unpredictable. And yes, I'm using the correct HTML tags, Lithium.

 

I think the new editor was a case of a lot of bling, but no bang.

Knight of NI
Ray.R
Posts: 10,584

Re: Unexpected behavior while trying to post reply

I had been away from the forum for almost 6 months when they did this upgrade.  I popped in & out casually, but did not post much. 

I think I do remember when the change was made and probably posted a complaint about it.  

 

I really miss the old editor, which to my opinion was far better than this one.

 

With impared vision, I have to look at the keyboard when typing, so I do not notice when the bloody browser refreshes the window, so it often screws up my initial sentence.  Going back to the first page was a bit surprising for me, thus this thread.  

 

I wonder if Laura would ever consider getting Lithium to go back to the good old editor.  :smileyhappy:  Maybe we should start a poll..

______________________________________________________________________
Kudos!!!! Gimme Kudos!!!! It's that little golden star on the left below my avatar... :smileyhappy: