Feedback on NI Community

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Snippets are broken?

Snippets are broken?

From here

You just get this:

Capture.PNG

No more "Poof its code?"  that stinks

 

0 Kudos
Message 1 of 15
(265 Views)

Re: Snippets are broken?

Hi Jeff,

 

The issue seems specific to that particular image and how it was uploaded. Please let us know if you are seeing the issue in other posts.

 

Thanks,

Lili

~~~~~~~~~
Message 2 of 15
(209 Views)

Re: Snippets are broken?

I'm seeing that same problem also.

 

With this post.  http://forums.ni.com/t5/LabVIEW/The-distribute-object-tools-often-crashes-LabVIEW-2017/m-p/3659157#M...

 

Interestingly, that looks more like a Code Capture Tool snippet rather than LV built-in VI snippet.

 

And that brings up the question, how have people been installing the CCT in LV 2017?  Recent versions of LV, I've used JKI VIPM to install the CCT.  But VIPM doesn't seem to be updated yet to work with LV 2017.

0 Kudos
Message 3 of 15
(202 Views)

Re: Snippets are broken?


RavensFan wrote:

I'm seeing that same problem also.

 

With this post.  http://forums.ni.com/t5/LabVIEW/The-distribute-object-tools-often-crashes-LabVIEW-2017/m-p/3659157#M...

 

Interestingly, that looks more like a Code Capture Tool snippet rather than LV built-in VI snippet.

 

And that brings up the question, how have people been installing the CCT in LV 2017?  Recent versions of LV, I've used JKI VIPM to install the CCT.  But VIPM doesn't seem to be updated yet to work with LV 2017.


I had no problem installing CCT through VIPM for 2017  Did you select VIPM from the options? (For some strange reason, I think I recall that it was unchecked by default in the installer- but, don't quote me on that.)

0 Kudos
Message 4 of 15
(198 Views)

Re: Snippets are broken?

Read that linked message thread for more info.  Blokk seems to have found the problem with the VI snippets.  The new "Image" tool on the forums seems to be breaking the snippet.  When he attached the actual png file, I was able to insert that one just fine into LabVIEW.

0 Kudos
Message 5 of 15
(190 Views)

Re: Snippets are broken?


Jeff·Þ·Bohrer wrote:



I had no problem installing CCT through VIPM for 2017  Did you select VIPM from the options? (For some strange reason, I think I recall that it was unchecked by default in the installer- but, don't quote me on that.)


Thanks Jeff.  I 'll check that out.  Do you mean as an option within the LabVIEW installer when I first installed LV 2017?

 

I don't remember seeing that in there.  I had always installed VIPM based on a download from JKI.  Or it updated itself when it detected updates.  JKI's website still says 16.0.???? is the latest for download.

 

I know I needed to deselect some options when installing LV 2017.  (For example, the Windows/CVI, why does it think I'd want to install that?)  And I minimized the amount of extra modules I installed since I'm running low on drive space.  But I just don't remember seeing anything about VIPM in there.

0 Kudos
Message 6 of 15
(187 Views)

Re: Snippets are broken?


RavensFan wrote:

 JKI's website still says 16.0.???? is the latest for download.


Despite the page stating it is 16, the download link is for 17.  There is a thread on JKI's forums that has some confusion and has gone unanswered (along with another on LAVA at one point)


Unofficial Forum Rules and Guidelines - Hooovahh - LabVIEW Overlord
Interesting in learning all you can about automotive CAN bus communicatin? Checkout my 9 part CAN Blog series.

Message 7 of 15
(176 Views)

Re: Snippets are broken?


RavensFan wrote:

Jeff·Þ·Bohrer wrote:



I had no problem installing CCT through VIPM for 2017  Did you select VIPM from the options? (For some strange reason, I think I recall that it was unchecked by default in the installer- but, don't quote me on that.)


Thanks Jeff.  I 'll check that out.  Do you mean as an option within the LabVIEW installer when I first installed LV 2017?

 

I don't remember seeing that in there.  I had always installed VIPM based on a download from JKI.  Or it updated itself when it detected updates.  JKI's website still says 16.0.???? is the latest for download.

 

I know I needed to deselect some options when installing LV 2017.  (For example, the Windows/CVI, why does it think I'd want to install that?)  And I minimized the amount of extra modules I installed since I'm running low on drive space.  But I just don't remember seeing anything about VIPM in there.


Honestly I just got my media last week.  I upgraded a few machines via download and recall that I had to go and check a bunch of stuff I expected to automatically install, VIA, UTF, VIPM, DETT and some others.  For upgrading a "Pro" key (actually an Alliance Partner Lease) the install options from the download were poor.  It did check my system- and should have selected some better options based on my current configuration.  I expect when I plug that 64GB USB Drive into my Laptop things will go a bit smoother.

Message 8 of 15
(172 Views)

Re: Snippets are broken?

Thanks Hoovahh and Jeff,

 

it hadn't been a high priority for me because I'm not actively developing in 2017 yet.  Just using it for the sake of the forums.  But of course the code capture tool is the one thing that is most helpful with supporting the forums.  I'll try on of those tips in the next day or so.

0 Kudos
Message 9 of 15
(165 Views)

Re: Snippets are broken?

We have escalated the issue with VI Snippets to our community provider for further investigation. We will post updates when available.

~~~~~~~~~
Message 10 of 15
(116 Views)