NI Home > Community > NI Discussion Forums

FOUNDATION Fieldbus

Showing results for 
Search instead for 
Do you mean 
Reply
Member
lurbanov
Posts: 2
0 Kudos

NI-FBUS Crash with FFeasy

I am using the FFeasy board from Softing with NI-FBUS Configurator version 3.2.3. When I start the configurator, the Communications Manager crashes. The error messages in the Configurator are NIF_ERR_INVALID_DESCRIPTOR and NIF_ERR_SERVER_CONNECTION_LOST. Is this being caused by an error in the Softing DD or a problem with the settings in the Configurator?

 

 

Member
Chris.W
Posts: 82
0 Kudos

Re: NI-FBUS Crash with FFeasy

Please let me clarify several questions with you:

 

1. Which type of NI-FBUS interface did you use? USB-8486, PCI-FBUS series 2 Card? or something?

2. What kind of crashing did you mean with Communications Manager? A screen shot will be better for checking.

3. A quick way to find out the possible problem relies in it to connect another device, other than Softing one, to the H1 network. And run Configurator to see whether any problem happens.

 

If you are suspecting the Softing DD file, you could try it with offline interface.

 

Should you have any questions, please let me know.

Thanks.

Member
lurbanov
Posts: 2
0 Kudos

Re: NI-FBUS Crash with FFeasy

Thanks for the reply. Softing was able to help me with this issue. There was a problem with the NI-FCS Standard-Dictionary file (nifb.dct). Softing provided me with an updated version of this file and it corrected the issue.

 

 

Member
Chris.W
Posts: 82
0 Kudos

Re: NI-FBUS Crash with FFeasy

Oh, that is great to hear that.

Good luck and have fun with our NI-FBUS software.

Thanks.