NI Home > Community > NI Discussion Forums

Dynamic Signal Acquisition

Showing results for 
Search instead for 
Do you mean 
Reply
Member
mssaleh
Posts: 4
0 Kudos

"national instruments dsa not detected" 4551 driver

Hi there,

 

I tried to install 4551 dsa driver using NI-DAQ 7.4.4 and NI-DSA 2.1 but when I launched the soft front panel application of DSA 2.1 the following error was appeared "national instruments dsa not detected".

 

The PCI device in device manager is not installed yet and I tried many ways to install the device driver but unsuccessful attempt.

 

Please let me know if you have any idea

 

Thanks

Sadeq

Member
Finnabon
Posts: 102
0 Kudos

Re: "national instruments dsa not detected" 4551 driver

Hi mssaleh,

 

I have some questions for you to help me better troubleshoot your situation.

What operating system are you using?

Are the LEDs on your device on? Please describe all the LEDs you see.

Does this card appear in Measurement & Automation Explorer (MAX)?

Is the device appearing as "PCI Device" with the yellow exclamation mark in Device Manager?

Do you have DSA driver version 1.2 or 2.1? 

 

Kind Regards,

 

Allie

 

 

Member
mssaleh
Posts: 4
0 Kudos

Re: "national instruments dsa not detected" 4551 driver

Hi Allie,

 

- I have tried some operating systems; Windows Seven Pro, Windows XP, Windows 98, Windows 2000. It seems the Ni-DAQ drivers installed completely.

- Actually I've tried the hardware on different systems and the the green LED blinking in different ways; on a Pentium 3 motherboard it was blinking continuously, but on a Pentium 4 motherboard it blinking until the operating system uploaded.

- No, the device does not appear in MAX.

- Exactly, the device appearing as "PCI Device" with yellow exclamation mark in device manager.

- I apologize for typo I've installed NI-DSA 1.2

 

I want to mention that in my investigation for solution I found that the hardware configuration (Hardware Ids) state the vendor as 1013 for my 4551 but the PCI-4551 card defined in NIDAQ2.inf with vendor of 1093 so it seems completely reasonable that the drivers can not be detected by windows.

 

Thanks

Sadeq

 

 

 

 

Member
Finnabon
Posts: 102
0 Kudos

Re: "national instruments dsa not detected" 4551 driver

Hi Sadeq,

 

First things first, the NI-DAQ 7.4.4 and DSA 1.2 are only supported on Windows 2000 or XP, so only try the card on those systems. The 1013 is the vendor ID of a different company, so I am wondering if this PCI device entry is even for the 4551. Is there any other entry in your Device Manager? Can you take a screenshot of Device Manager and the Hardware ID info of your devices?

 

Allie 

Member
mssaleh
Posts: 4
0 Kudos

Re: "national instruments dsa not detected" 4551 driver

I'm sure that the other slots are empty. You can find the screenshots and photos in the attachment.

 

Thanks

Sadeq

Member
Finnabon
Posts: 102
0 Kudos

Re: "national instruments dsa not detected" 4551 driver

Hi Sadeq,

 

I completely believe you are using the 4551, but it is suspicious that the PCI Device's vendor ID is 1013 since this is the Vendor ID for Cirrus Logic. Have you verified that this PCI device entry is only there when the card is in the computer?  Have you tried this card in another computer? If so, what kind?

 

Have you tried to force this card to identify with the NI driver by manually selecting what the card should be identifying as?

 

Allie

Member
mssaleh
Posts: 4
0 Kudos

Re: "national instruments dsa not detected" 4551 driver

Hi Allie,

 

I don't have any idea about what is happening but I'm sure that this entry is completely related to the 4551's hardware and it appears when the 4551 card is installed. I've tried the card on some different computers; some of them do not detect the device at all and others detected it with the same entry of 1013.

I tried this card on pentuim3 system with soltek motherboard.

 

Actually, I tried to change the nidaq2.inf DRIVER FILE (not the hardware setting) once to be compatible with vendor of 1013 but it was not effective because I couldn't find the necessary access to the nidaq32.dll to change the necessary registries.

 

I wondering why it is not working on any pentuim4 systems, is there any PCI configuration should be applied in BIOS setting?

 

Sadeq

Thanks

 

 

Member
Finnabon
Posts: 102
0 Kudos

Re: "national instruments dsa not detected" 4551 driver

Hi Sadeq,

 

Unfortunately, my resources are limited since this is a considerably old card. It appears, however, that this card is defective since it is not detecting properly. You may contact your sales representative to see if there are any options for repair or for upgrading to a current model.