NI Home > Community > NI Discussion Forums

Discussions au sujet des autres produits NI

Affichage des résultats de 
Rechercher plutôt 
Voulez-vous dire 
Répondre
Member
nozeart
Envois : 11
0 Compliments

probleme avec Imaq write file qui n'enregistre pas les images en jpg

Bonjour,

 

dans le cadre d'un stage, je suis en train de dévellopper un programme qui récupère une vidéo issue d'une caméra usb. Jusque là tout vas bien. Mais je souhaite réalisé une vidéo a partir d'une suite d'image au format jpeg que le programme aura enregistrer dans un dossier.

 

Mon probleme etant que Imaq write file 2 que j'utilise n'arrive pas a enregistrer les image au format jpg (alors qu'il y arrive au forma png, tiff ou jpg2000). Ainsi, lorsque je lance la capture, le programme a l'air de faire des opération mais lorsque je vais dans le dossier où doivent etre entreposé les jpeg, celui ci est vide.

 

J'utilise labview 2010 et suis sous windows 7 x64 bits.

 

Merci d'avance pour l'aide que vous pourez m'apporter.

Trusted Enthusiast
TiTou
Envois : 2 976
0 Compliments

Re: probleme avec Imaq write file qui n'enregistre pas les images en jpg

bizarre... tu peux montrer ton code?

_______________________________________________________________________
When my feet touch the ground each morning the devil thinks "bloody hell... He's up again!"
Member
nozeart
Envois : 11
0 Compliments

Re : probleme avec Imaq write file qui n'enregistre pas les images en jpg

Member
nozeart
Envois : 11
0 Compliments

Re : probleme avec Imaq write file qui n'enregistre pas les images en jpg

Je vien de m'appercevoir que ma version de labview est en 32 bits est ce que ça peut influer sur ce probleme?

Member
Nicolas_NIF
Envois : 186
0 Compliments

Re : probleme avec Imaq write file qui n'enregistre pas les images en jpg

Bonjour,

 

Merci d'avoir posté sur le forum NI.

 

Votre problème est il résolu?

Pourquoi souhaitez vous passer en Jpeg si le png fonctionne?

 

Cordialement,

Nicolas M.
National Instruments France


Journées Techniques LabVIEW 2012 : du 27 septembre au 22 novembre
2 sessions en parallèle : Débuter a...

Member
nozeart
Envois : 11
0 Compliments

Re : probleme avec Imaq write file qui n'enregistre pas les images en jpg

Bonjours,

 

Mon probleme est résolu j'ai modifier le code affin d'enregistrer de maniere differentes et maintenant ça enregistre bien en jpeg.

 

Il faut que j'enregistre en jpeg pour un souci d'espace sur le disque car on prend plusieur centaine (voir millier) de photo pour une video donc c'est plus interessant en jpeg qu'en png

Trusted Enthusiast
TiTou
Envois : 2 976
0 Compliments

Re : probleme avec Imaq write file qui n'enregistre pas les images en jpg


nozeart wrote:

Je vien de m'appercevoir que ma version de labview est en 32 bits est ce que ça peut influer sur ce probleme?


Non, ça ne devrait pas poser de problème.

 

Est-ce que tu as une erreur à la sortie du "write"?

Vu que ton chemin vient d'un chaine convertie en chemin, il y a un risque que le chemin que tu donnes pour l'image ne soit pas formé correctement, peux tu mettre une sonde sur le chemin que tu donne au write?

_______________________________________________________________________
When my feet touch the ground each morning the devil thinks "bloody hell... He's up again!"