NI Home > Community > NI Discussion Forums

DIAdem

Showing results for 
Search instead for 
Do you mean 
Reply
Member
Rauppson
Posts: 3
0 Kudos
Accepted Solution

x-axis just takes 1st value for all datas

Hello,

 

my problem is as follows:

 

I got very much datas like this in the dataportal:

[1] friction

    +[1] way

    +[1] force

 

[2] friction

    +[2] way

    +[2] force

 

 

and i want to bring them in this form:

 

 x- axis         |     y-axis

 

[1] way           [1] force

[2] way           [2] force

 

 

But when i select them all and put them in the report or view i only get this:

 

 x- axis         |     y-axis

 

[1] way           [1] force

[1] way           [2] force

 

 

How can i change this?

as i said i got really much datas... so changing every single one is not an option

 

Thank you for helping!

Active Participant
DRock
Posts: 244
0 Kudos

Re: x-axis just takes 1st value for all datas

Hi Rauppson -

 

You say "...when I select them all and put them in REPORT or VIEW..."  

 

Are you selecting all of the channels at one time?  If so, REPORT and VIEW both interpret your selection by using the first channel selected as the X-Channel and graphing the rest of the channels as Y-Channels.  This is why each of your channels is being graphed versus the original X-Channel.

 

One option for you is to drag each Channel Group into REPORT or VIEW.  This will graph each of the channels in a group using the first channel in the group as the X-Channel.

 

However, if you have many many channels, you may want to try using Curve Expansion.  To enable Curve Expansion in REPORT, choose Settings » Layout Setup » Layout Parameters.  Select the Curve Expansion button and check the box for Expand Curves.  

 

This procedure will allow you to add one single X-Channel and Y-Channel pair to a graph in REPORT, but DIAdem will then graph all instances of that identical X-Channel and Y-Channel name that it finds in the Data Portal, even if the Channels exist in different Channel Groups..  You can read more about the procedure here:

 

http://zone.ni.com/reference/en-XX/help/370859J-01/dlgpresent/graph_2d_sizeoriented/dlgpicdefexplist...

 

Let us know if this helps you!

 

Derrick S.
Product Manager
NI DIAdem
National Instruments
Member
Rauppson
Posts: 3
0 Kudos

Re: x-axis just takes 1st value for all datas

Hi DRock,

 

thank you for your quick answer.

 

 

"Are you selecting all of the channels at one time?  If so, REPORT and VIEW both interpret your selection by using the first channel selected as the X-Channel and graphing the rest of the channels as Y-Channels.  This is why each of your channels is being graphed versus the original X-Channel."

 

Yes i am selecting all of the channels at one time and this is exactly my problem that REPORT and VIEW are only using the first channels selected as the X-Channel.

 

I can't drag each channel into REPORT or view because i got about 150 channels for 1 measurement and at that time 12 measurements and it's getting more.

 

I tried this option with the curve expansion. The result is close to the result i wanted to have but here i got the problem that all curves have the same color and it's very difficult to look at one single measurement. (I need this because i want to sort "bad" measurements out and have a closer look at them)

 

Do you have any other suggestion for this problem?

 

 

 

Active Participant
DRock
Posts: 244
0 Kudos

Re: x-axis just takes 1st value for all datas

Hi Rauppson -

 

When you enabled Curve Expansion, did you take a look at the bottom part of the dialog box?  If you enable the "Properties List" checkbox it will allow you to specify colors used for the individual curves instead of using the same color.

 

Curve Expansion.png

 

The result would look something like this:

 

Curve Expansion2.png

 

Let us know if this does not work for you?

Derrick S.
Product Manager
NI DIAdem
National Instruments
Member
Rauppson
Posts: 3
0 Kudos

Re: x-axis just takes 1st value for all datas

Ah sorry, I did not recognize this

This is exactly the result i wanted to have.

 

Thank you very much!