NI Home > Community > NI Discussion Forums

Circuit Design Suite

Showing results for 
Search instead for 
Do you mean 
Reply
Member
getamazed
Posts: 2
0 Kudos

multisim 9:- "Simulation shows error:no such file"

I am a new user with Multisim.

Everytime i start simulation, the Simultion Error/Log shows "Error: C\Docume~1\D: No such file or directory".

I have installed the multisim on my G drive.

Could someone please tell me how to simulate and get rid of this error.

Or tell me what all settings must be made before any simulation.
Member
Bhavesh
Posts: 34

Re: multisim 9:- "Simulation shows error:no such file"

During simulation, Multisim creates a temporary file which is saved to the C:\ drive which contains the actual simulation output. This is the file that Multisim is having difficulty finding. This file path is set by environment variables. If you are in a situation where you do not have write access to your C drive (since you are installed on your G:\) drive I would recommend changing your environment variables with the following procedure:
 
1.) Start >>Control Panel >> System
2.) Click on the "Advanced" tab
3.) Click on the "Environment Variables" button
4.) Change the TEMP and TMP environment variables to point to a place where you have write access, such as on the G drive.
 
 
 
Member
getamazed
Posts: 2
0 Kudos

Re: multisim 9:- "Simulation shows error:no such file"

Hi bhavesh, thanks.

I am the administrator on my computer. So i have access to my c drive. Do i have to change some settings for the multisim 9 or can i change the location where multisim creates the temporary file?

 

Member
Bhavesh
Posts: 34
0 Kudos

Re: multisim 9:- "Simulation shows error:no such file"

Although the error I mentioned is for Administrator vs. User access, I would recommend that you try the listed solution, as it will still get you simulating correctly. The problem here is that there is some read/write issue with that particular folder on your computer so changing the environment variables should fix the problem.
Member
rafailka
Posts: 1
0 Kudos

Re: "error:no such file"

I have had just the same problem with NI Multisim 10 Education Edition, Version 10.0.144. The solution described worked fine. I've only had to change the %TEMP% environment variable.

I dare suppose that Multisim does not support national alphabet characters in temporary folder name. In my case Windows user account name consisted of Cyrillic characters. So, creating a different user account (with only English letters in its name) also solves the problem.