NI Home > Community > NI Discussion Forums
Reply
Member
RPMatVJ
Posts: 2
0 Kudos

invalid subckt definition name

Not sure why the below errors occur. I created the attached IPD135N031.cir file from the OptiMOS3_30V_40V.lib file (changed to a txt file in order to post). I use the IPD135N031.cir file in the Select Simulation model > Load From File step 6 of the Component Wizard. 

 

 

------ Checking SPICE netlist for diode driver - Wednesday, May 18, 2011, 1:33:32 PM ------
SPICE Netlist Error in schematic RefDes 'u1', element 'x1':  Invalid subckt definition name 's4_30_h_var'
SPICE Netlist Error in schematic RefDes 'u1', element 'ipd135n03l__mosfet__2':  Due to errors, the subckt instance 'x1' has been omitted from the simulation
SPICE Netlist Error in schematic RefDes 'u1', element 'xu1':  Not enough nodes found
======= SPICE Netlist check completed, 3 error(s), 0 warning(s) =======

 

Thanks

Active Participant
Tien_P
Posts: 1,085
0 Kudos

Re: invalid subckt definition name

[ Edited ]

Hi,

 

 

In IPD135N031.cir file you attached, there is a line that starts with:

X1  d1 g s Tj S4_30_h_var

 

This line is a call command in spice, it's looking for another model called :s4_30_H_H_var.  You did not include the second model and that's why you got the error message.

 

The attached file is the complete model.  I made one modification to the syntax that you should know about.  In the model, one of the expressions has a log function.  If left that way, Multisim will treat log()expression as ln(), otherwise you have to use log10.  I changed the expresssion to log10.

Tien P.

National Instruments
Member
RPMatVJ
Posts: 2
0 Kudos

Re: invalid subckt definition name

Thanks for the reply. I used the file and now have different errors as shown in the attached file.

 

 

Active Participant
Tien_P
Posts: 1,085
0 Kudos

Re: invalid subckt definition name

Hi,

 

 I created a new component in V11 and didn't get any error.  If you are using V10 or older, this model will not work because there are parameters that was not supported in the older versions.

 

Tien P.

National Instruments
Member
crsn
Posts: 2
0 Kudos

Re: invalid subckt definition name

Hi, I use multisim 11 and I was creating a LM386 schematic amplifier symbol.....when I try to simulate my circuit I get this message:

------ Checking SPICE netlist for LM386_VoltageGain_10 - Thursday, March 22, 2012, 3:19:02 PM ------
SPICE Netlist Error in schematic RefDes 'u1', element 'xu1':  Invalid subckt definition name 'u1_open_gain8'
SPICE Netlist Error in schematic RefDes 'u1', element '<unknown>':  Due to errors, the subckt instance 'xu1' has been omitted from the simulation
======= SPICE Netlist check completed, 2 error(s), 0 warning(s) =======

 

Any suggestion on how to fix this error?