NI Home > Community > NI Discussion Forums
Reply
Member
Omatthews
Posts: 5
0 Kudos
Accepted Solution

How to use Vernier Bioinstrumentation Sensor kit with the NI ELVIS II and LABview on a CPU?

So I have the NI ELVIS II+, and a Box full of Sensors from the Bioinstrumentation Sensor Kit, including: Analog Proto board connector(s),Blood Pressure Sensor, Hand Dynamometer, Hand grip Heart Rate Monitor, EKG Sensor, Surface Temperature Sensor, among others.

 

I just can't seem to get any data from the Sensors to my PC i'm using, i'm not too familiar with Electrical circuits but i follow the manual directions for the specific sensor but it seems as if it doesn't make a difference. I'm using copper hook up wires and connecting them to the appropiate places (according to the manual) but nothing.

 

Am i missing something? I also have the whatever the specific LABview lab is open (Surface Temp Lab for example), but when i press run its like the sensors aren't recognized or even being acknowledged. The sensors are plugged into the analog Proto Board Connectors also. What am i doing Wrong, and how can I get these sensors to work?

 

Any help will be greatly appreciated.

 

Member
-_Luis_Martinez_-
Posts: 54
0 Kudos

Re: How to use Vernier Bioinstrumentation Sensor kit with the NI ELVIS II and LABview on a CPU?

Hello Omatthews, Hope you are doing great.

 

Here you can take a look to the getting started  with the Vernier Bioinstrumentation from our website, I think this is useful if you are looking for general informatiom about the NI Elvis and Bioinstrumentation.

 

This second video also shows you the Bioinstrumentation interaction with NI-Elvis and Labview. I will recommend to take a look at them so you get familliar with the enviroment, maybe is just a small step we are missing so everything works.

 

Let us know If after seeing the videos you still have questions about it, the connection should be straight forward,

 

It will be our pleasure to help.

 

Luis A.

Applications Engineer.

National Instruments. 

Member
Omatthews
Posts: 5
0 Kudos

Re: How to use Vernier Bioinstrumentation Sensor kit with the NI ELVIS II and LABview on a CPU?

Thank you for the reply, I'm going to watch the tutorials and see where I can go from there. If i have anymore questions i will be sure to post them here. Once again thank you for the reply

Member
-_Luis_Martinez_-
Posts: 54
0 Kudos

Re: How to use Vernier Bioinstrumentation Sensor kit with the NI ELVIS II and LABview on a CPU?

Hello,

 

It is a pleasure, hope this information helps!

 

Feel free to post sure there is somebdoy looking to help!

 

regards, 

 

Luis A.

Member
Omatthews
Posts: 5
0 Kudos

Re: How to use Vernier Bioinstrumentation Sensor kit with the NI ELVIS II and LABview on a CPU?

Alright, so I'm sort of back to square 1. The thing is I have nearly no knowledge of circutry and how circuits work; or building a circuit.I watched the bioinstrumentation 102 video and it seems she set up her own Lab from scratch.I'm not creating the LAB in Lab view from scratch i'm a lab code that has already been set up called NI Temperature Lab.

 

I'm trying to aquire simpe data like temperature, max temperature, and min temperature using the Vernier Surface Temperature sensor that came in the Bioinstrumentation kit.

 

I've followed the instructions of the Temperature Lab document and set up the wires like it said and exactly like the picture the lab directions provided:

 

" Connect the following pins to wire the connector:

  1. AI0+ to SIG1 of the Analog Proto Board Connector

  2. +5V DC power supply to 5V of the Analog Proto Board Connector

  3. GROUND power supply to GND of the Analog Proto Board Connector

  4. AIGND to GND of the Analog Proto Board Connector "

And i'm using the labview  NI Temperature Lab along with it. I figured once everything was hooked up i could test the temperature using my own body temperature by just hittin run but i'm not getting an accurate reading, and when i do get a reading it seems to be just random data.

 

The surface temperature sensor is snapped in to the analog proto board connector and everything is on and in place. Now is there something else I have to do, do I actualy have to change some of the setings in the block diagram, or am i missing something? I just want the data to be transferred from real world activity onto the computer using Labview. How do i get proper readings? Do you have any idea what could be the reason I cant get any data?

 

Thank you

 

 

Member
-_Luis_Martinez_-
Posts: 54
0 Kudos

Re: How to use Vernier Bioinstrumentation Sensor kit with the NI ELVIS II and LABview on a CPU?

Hello again, hope you are doing great!

Seems to me that you are following the proper steps as per the manual says, is there a way you can post the Lab/code so I can take a look at it, however should be a staright forward process.
I can´t think of a steps that need to be done before setting up the hardware or software, however you can verify that the DAQ assistant on the block diagram is configured properly meaning the NI ELVIS is selected and the proper channels are in fact the ones you have connected to the vernier instrument and the ELVIS board. Code-wise there is not much that can be interfering with our acquisition, as far as I know we use the DAQ assistant express VI where the only setup available is the Device and channel you will use.

 

Let me know how it goes,

 

Luis A

National Instruments.

Member
Omatthews
Posts: 5
0 Kudos

Re: How to use Vernier Bioinstrumentation Sensor kit with the NI ELVIS II and LABview on a CPU?

Hello, I'm doing good and will be doing Great once i can get this to work.

 

I'm sorry but where would i find the Lab code, i can attach the .vi that i am using and maybe you can check out the block diagram.

 

Thanks again for the help, I'm a Material Technology Major and I'm using this NI Elvis for my senior project as a Bio-medical lab. I didn't think I would have to know much about circuits and wiring but it seems i was mistaken. Figured once it was wired i could begin acquiring data using several sensors but there must be some underlying factor i haven't noticed

Member
I.Foldvari
Posts: 35

Re: How to use Vernier Bioinstrumentation Sensor kit with the NI ELVIS II and LabVIEW on a CPU?

From what I can see it looks like a typo in the manual.

Try to connect GND to AI0- and NOT AGND.

 

It should look like this.

 

Connect the following pins to wire the connector:

  1. AI0+ to SIG1 of the Analog Proto Board Connector

  2. +5V DC power supply to 5V of the Analog Proto Board Connector

  3. GROUND power supply to GND of the Analog Proto Board Connector

  4. AI0- to GND of the Analog Proto Board Connector 

Regards
Ingo Foldvari
Area Sales Manager - US West Academic
National Instruments
Member
Omatthews
Posts: 5
0 Kudos

Re: How to use Vernier Bioinstrumentation Sensor kit with the NI ELVIS II and LabVIEW on a CPU?

Thank you so much I.Foldvari for that correction, I wish i could shake you hand! I wired it as you stated and the Lab worked flawlessly. The other sensors that I have are pretty similar in set up so from here on out I should be able to aquire the data i need to complete my project.

 

 

Also thank you LuisAE for your efforts and help also.